uva350 - Pseudo-Random Numbers

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( tex2html_wrap_inline32 , where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

tabular21

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220

#define LOCAL
#include <cstdio>
#include <iostream>
#include <cstring>

using namespace std;
const int maxn = 100000;
int arry[maxn];
bool check(int L, int j)
{
	for(int i = 0; i < j; ++ i)
	{
		if(arry[i] == L)
		{
			return false;
		}
	}
	return true;
}
int main()
{
#ifdef LOCAL
    freopen("data3.in", "r", stdin);
    freopen("data3.out", "w", stdout);
#endif
	int L, I, M, Z;
	int casee = 1;
	while(scanf("%d %d %d %d", &Z, &I, &M, &L) != EOF
		&& Z != 0 && I != 0 && M != 0 && L !=0)
	{
		int j = 0;
		int cnt = 0;
		L = (Z * L + I) % M;  ///But be careful: the cycle might not begin with the seed! (very important!)
		arry[j++] = L;
		cnt++;
		L = (Z * L + I) % M;
		   ///able optimize
		while(check(L, j))
		{
			arry[j++] = L;
			cnt++;
			L = (Z * L + I) % M;
			//printf("L = %d\n", L);
		}
		printf("Case %d: %d\n",casee++, cnt);

	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值