hdu1028 Ignatius and the Princess III

Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11935    Accepted Submission(s): 8450


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
   
   
4 10 20
 

Sample Output
   
   
5 42 627
 题目大概意思就是一个整数可以划分成多少种不同的数有多少种。很经典的一道dp题。
思想:
 如果一个整数i,划分成j是怎么划分的。
        第一种情况:j==1||i==1 时只有1种;
第二种情况:j==i 那么f(i,i)=f(i,j-1)+1;
第三种情况:j<i 时那么f(i,j)=f(i,i);
第四重情况:i>j 时那么 f(i,i)=f(i-j,j)+f(i,j-1);
但是我想告诉你的是会超时。所以就得转换成dp了。
/*递归超时
#include<stdio.h>
int fun(int n,int m)
{
	if(n==1||m==1)
		return 1;
	if(n==m)
		return fun(n,m-1)+1;
	if(n<m)
	   return fun(n,n);
	if(n>m)
		return fun(n-m,m)+fun(n,m-1);
}
int main()
{
	int i,j,n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",fun(n,n));
	}
	return 0;
}
*/
#include<stdio.h>//ac代码
#include<string.h>
int main()
{
	int n,i,j,dp[200][200],k;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof dp);
		dp[0][0]=1;
		for(i=0;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(j<=i)
					dp[i][j]=dp[i-j][j]+dp[i][j-1];
				else
					dp[i][j]=dp[i][i];
			}
			printf("%d\n",dp[n][n]);
	}
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值