Combinations(组合数学)

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15


题意 : 输入n,k ,输出 C[n][k] (Cn k);


#include <iostream>
#include <cstdio>
#define LL long long
using namespace std;
const int maxn=1000005;
const int mod =1000003;

LL f[maxn],ni[maxn];
int n,k,T;

LL pow_mod(LL num,int t)    //  快速幂求逆元
{
    LL p=num,q=t,ret=1;
    while(q)
    {
        if(q & 1)  ret = ret*p%mod;
        q>>=1;
        p=p*p%mod;
    }
    return ret%mod;
}

void initial()
{
    f[0]=f[1]=1;
    ni[0]=ni[1]=1;
    for(int i=2;i<maxn;i++)
    {
          f[i]=f[i-1]*i%mod;
          ni[i]=pow_mod(f[i],mod-2);
    }
}

int main()
{
     initial();
     scanf("%d",&T);
     for(int co=1;co<=T;co++)
     {
           scanf("%d %d",&n,&k);
           printf("Case %d: %lld\n",co,f[n]*ni[k]%mod*ni[n-k]%mod);
     }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值