poj 2151 Check the difficulty of problems (概率DP)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5006 Accepted: 2203

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972
 
 
题意:ACM比赛中,共M道题,T个队,pij表示第i队解出第j题的概率,问每队至少解出一题且冠军队至少解出N道题的概率。

思路:  dp[i][j][k] 表示第i个对在前j题解出k题的概率,sum[i][j]表示第i个对最多解出j题的概率。
 
   dp[i][j][k] = dp[i][j-1][k]*(1-p[i][j]) + dp[i][j-1][k-1]*p[i][j];
   sum[i][j]= dp[i][m][0]+dp[i][m][1]+...+ dp[i][m][j];
   
每队至少解出一题的概率 : ans1 = (1- sum[1][0])* (1- sum[2][0])*  ......* (1- sum[m][0]) ;
                每个队解出题但小于n道的概率 :ans1 = ( sum[m][n-1]- sum[1][0])* 
sum[m][n-1]- sum[2][0])*  ......* 
sum[m][n-1]- sum[m][0]) ; 
                所以最后的答案  ans =  ans1-ans2;

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int M=1050;
const int N=35;

double dp[M][N][N],p[M][N],sum[M][N];
int n,m,t;

void input()
{
     for(int i=1;i<=t;i++)
         for(int j=1;j<=m;j++)
               scanf("%lf",&p[i][j]);
     memset(dp,0,sizeof(dp));
}

void solve()
{
    for(int i=1;i<=t;i++)
    {
        dp[i][0][0]=1.0;
        for(int j=1;j<=m;j++)
            for(int k=0;k<=j;k++)
            {
                dp[i][j][k]=dp[i][j-1][k]*(1-p[i][j]);
                if(k!=0) dp[i][j][k]+=dp[i][j-1][k-1]*p[i][j];
            }

        sum[i][0]=dp[i][m][0];
        for(int j=1;j<=m;j++)  sum[i][j]=sum[i][j-1]+dp[i][m][j];
    }
    double ans1=1.0,ans2=1.0;
    for(int i=1;i<=t;i++)
    {
        ans1*=(1.0-sum[i][0]);
        ans2*=(sum[i][n-1]-sum[i][0]);
    }
    printf("%.3f\n",ans1-ans2);
}

int main()
{
    while(scanf("%d %d %d",&m,&t,&n)!=EOF)
    {
         if(m==0 && t==0 && n==0)  break;
         input();
         solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值