HDU 3079 Vowel Counting 元音字母大写

Vowel Counting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1485    Accepted Submission(s): 1092

Problem Description
The "Vowel-Counting-Word"(VCW), complies with the following conditions.
Each vowel in the word must be uppercase.
Each consonant (the letters except the vowels) must be lowercase.
For example, "ApplE" is the VCW of "aPPle", "jUhUA" is the VCW of "Juhua".
Give you some words; your task is to get the "Vowel-Counting-Word" of each word.
 
Input
The first line of the input contains an integer T (T<=20) which means the number of test cases.
For each case, there is a line contains the word (only contains uppercase and lowercase). The length of the word is not greater than 50.
 
Output
For each case, output its Vowel-Counting-Word.

Sample Input
  
  
4 XYz application qwcvb aeioOa
 
Sample Output
  
  
xyz ApplIcAtIOn qwcvb AEIOOA

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3079

/*
元音字母大写 其他小写 
4
XYz
application
qwcvb
aeioOa 
*/
#include<iostream>
#include<cstring>
using namespace std;
int main(){
    int m,n,y,i,k;
    char str[51];
    cin>>m;
    while(m--)
    {
        scanf("%s",str);
        for(i=0;i<strlen(str);i++)
        {
            str[i]=tolower(str[i]);
            if(str[i]=='a') str[i]='A';
            if(str[i]=='e') str[i]='E';
            if(str[i]=='i') str[i]='I';
            if(str[i]=='o') str[i]='O';
            if(str[i]=='u') str[i]='U';
        } 
        printf("%s\n",str);
    } 
    
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值