Calendar

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. 
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years. 
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed. 
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday
这题首先设计两个函数,一个函数是用来计算年的天数,一个是用来计算月份的天数,然后在主函数中用调用函数的方式先由年开始,一级一级地往下减,这样就可以相应的得到年份,月份和天数;大概的思路就是这样:

#include <iostream>
using namespace std;
const char arr[][20]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int data_of_year(int year)
{
  if(year%100==0)
  {
    return year%400==0?366:365;
  }
  return year%4==0?366:365;
}
int data_of_month(int month,int year)
{
  if(month==2)
    return data_of_month(year)==366?29:28;
  int d;
  switch(month)
  {
  case 1:case 3:case 5:case 7:case 8:case 10:case 12:
  d=31;
  break;
  default:
  d=30;
  }
  return d; 
}
int main()
{
  int n;
  while(cin>>n)
  {
    if(n==-1)  break;
    int year=2000;
    int waek=n%7;
    int day=1;
    int month=1;
    while(n)
    {
      if(n>=data_of_year(year))
      {
        n-=data_of_year(year);
        ++year;
      }
      else if(n>=data_of_month(month,year))
      {
          n-=data_of_month(month,year);
          ++month;
      }
      else 
      {
        day+=n;
        n=0;
      }
    }
    cout<<year<<'-'<<(month>10?"0":"")<<month<<'-'<<(day>10?"0":"")<<" "<<arr[waek]<<endl;
  } 
  return 0;
}

最后一点就是需要注意一下输出的方式,我提交错误了一次原因就是这个坑爹的格式问题~~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值