NYOJ-287 Radar(贪心)

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
来源
Beijing 2002
上传者

ctest


思路:

       贪心算法;

       1. 把小岛看做圆心, 雷达的半径作为半径, 求这个圆与x轴的交点x, y; 那在x,y之间任意位置放置雷达都能覆盖小岛.既把小岛的坐标(xi,yi)转化成在x轴上的闭区间(x,y);

       2. 然后对所有小岛根据x升序排序,因为下一步放置雷达是从最左边往右放的;

       3. 令雷达的左端点x = 第一个小岛的y,然后不断向后覆盖其后小岛的左端点x,此时可能出现三种情况:

               a。雷达右端点y>小岛的左端点x,即此雷达可以覆盖该小岛,则继续;

               b。如果雷达的左端点x < 小岛的x坐标, 雷达肯定覆盖能此小岛,直接跳过。

               c。如果雷达的右端点y < 小岛的左端点x, 雷达的计数器加1,开始新的一轮循环;


代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>

using namespace std;
const int MAXN=1005;

struct Line
{
	double l,r;
}line[MAXN];//每个岛作半径为d的圆,截得区间

bool cmp(Line a, Line b)
{
	return a.r < b.r;
}

int main()
{
	int n, d;
	int i, x, y;
	int num=1, flag, count;
	while(scanf("%d %d",&n, &d) && n && d){
		flag = 1;
		for(i = 0; i < n; i ++){
			scanf("%d %d",&x, &y);
			if(!flag) continue;
			if(y <= d){
				line[i].l = (double)x - sqrt((double)d * d - y * y);
				line[i].r = (double)x + sqrt((double)d * d - y * y);
			}
			else flag = 0;
		}
		if(!flag){
			printf("Case %d: -1\n",num++);
			continue;
		}
		sort(line, line+n, cmp);
		count = 1;
		double now = line[0].r;
		for(i = 1; i < n; i ++){
			if(line[i].l <= now + 0.00005) continue;
			now = line[i].r;
			count ++;
		}
		printf("Case %d: %d\n", num++, count);
	}

	return 0;
}     


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值