radar(nyoj287贪心)

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
#include<stdio.h>
#include<math.h>
#include<stdlib.h>

#define MAX 1005

int num = 1;

struct land
{
	double l;
	double r;
}land_1[MAX];


int cmp(const void *a, const void *b)                          //  在c中运用qsort函数进行排序所需的自己的cmp函数标准模式
{
	return (*(struct land *) a). r > (*(struct land *) b). r ? 1 : -1;				//从小到大进行排序
}

int main()
{
	int count, r, x, y, flag, num_1, i;
	double now, result;


	while(scanf("%d%d", &count, &r) && count && r)
	{
		flag = 1;
		for(i = 0; i < count; i++)
		{
			scanf("%d%d", &x, &y);
			if(!flag)
			continue;
			if(y <= r)
			{
				result =sqrt((double) (r * r -  y * y));
				land_1[i].l = (double)x - result;
				land_1[i].r = (double)x + result;
	//			flag = 1;
			}
			else
				flag = 0;
			if(!flag)
			{
				printf("Case %d: -1\n", num++);
				continue;
			}	
		}
		qsort(land_1, count, sizeof(land_1[0]), cmp);				//qsort函数的用法
		num_1 = 1;
		now = land_1[0].r;
		for(i = 1; i < count; i++)
		{
			if(land_1[i].l <= now + 0.00005)
				continue;
			now = land_1[i]. r;
			num_1++;
		}
		printf("Case %d: %d\n", num++, num_1);
	}
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值