北邮OJ 2016网预 - Saber's Conjecture

15 篇文章 0 订阅
9 篇文章 0 订阅

题目描述

   In a parallel universe, young Saber-chan does not have a humongous appetite, instead, she likes studying math in her spare time. This afternoon when Saber-chan is plunged in her study, she came across an interesting conjecture: for any even number n greater than or equal to 4, there exists at least one pair of prime numbers  p1  and  p2  such that  n=p1+p2 .

    This conjecture is actually known as the Goldbach's conjecture. It is has not been proved nor refused yet. However in this universe, there are more programmers than mathematicians, people tend to prove math findings by programs. As the King of Knights and King of Britain, Saber-chan orders you to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

   A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that Saber-chan is interested in the number of essentially different pairs and therefore you should not count  (p1,p2)  and  (p2,p1)  separately as two different pairs.

输入格式

   An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to  4  and less than  215 . The end of the input is indicated by a number  0 .

输出格式

    Each output line should contain an integer number. No other characters should appear in the output.

输入样例

6
10
12
0

输出样例

1
2
1
题意就是求出一个数可以被写成多少种素数+素数的形式,比如

6=3+3

10=3+7,5+5

12=5+7

所以,筛出所有的素数的同时,将不是素数的数也标记好即可。

然后枚举x=2+(x-2)=3+(x-3)=...

#include<bits/stdc++.h>
#define N 100000
using namespace std;
int notpri[N];
 
int main(){
    int t,i,j,k;
    notpri[1]=1;
    int Lim=2<<15;
    for(i=2;i<Lim;i++){
        if(notpri[i]==0){
            for(j=2;j*i<Lim;j++){
                notpri[j*i]=1;
            }
        }
    }
 
 
    while(scanf("%d",&t)!=EOF){
        int res=0;
        if(t==0)break;
        for(i=2;i<=t/2;i++){
            if(notpri[i]==0&¬pri[t-i]==0)
                res++;
        }
        printf("%d\n",res);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值