HDOJ 2001 计算两点间的距离

计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 94488    Accepted Submission(s): 36264


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 

Sample Input
  
  
0 0 0 1 0 1 1 0
 

Sample Output
  
  
1.00 1.41
 

Author
lcy
 
第一次代码:
#include <stdio.h>
#include <math.h>
int main ()
{
    double x1,x2,y1,y2,d;
    while (scanf("%lf%lf%lf%lf",&x1,&x2,&y1,&y2)!=EOF)
    {
        d=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        printf ("%.2lf\n",d);
    }
    return 0;
}

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
111057402014-07-20 17:49:31Wrong Answer20010MS240K251 BC++Hidden Secret

第二次代码:
#include <stdio.h>
#include <math.h>
int main ()
{
    double x1,x2,y1,y2;
    while (scanf("%lf%lf%lf%lf",&x1,&x2,&y1,&y2)!=EOF)
    {
        printf ("%.2lf\n",sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)));
    }
    return 0;
}

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
111057902014-07-20 17:55:37Wrong Answer200115MS240K235 BC++Hidden Secret

第三次代码:
#include <cstdio>
#include <cmath>
int main()
{
    double x1, y1, x2, y2;
    while(scanf("%lf %lf %lf %lf", &x1, &y1, &x2, &y2) != EOF)
        printf("%.2lf\n", sqrt((double)((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))));
    return 0;
}

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
111058182014-07-20 17:59:19Accepted20010MS240K239 BC++Hidden Secret

第四次代码:
#include <cstdio>
#include <cmath>
int main()
{
    double x1, y1, x2, y2;
    while(scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2) != EOF)
        printf("%.2lf\n", sqrt((double)((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))));
    return 0;
}

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
111058282014-07-20 18:00:28Accepted20010MS240K236 BC++Hidden Secret

第五次代码:
#include <stdio.h>
#include <math.h>
int main ()
{
    double x1,x2,y1,y2,d;
    while (scanf("%lf%lf%lf%lf",&x1,&x2,&y1,&y2)!=EOF)
    {
        d=(double)sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        printf ("%.2lf\n",d);
    }
    return 0;
}

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
111058722014-07-20 18:05:16Wrong Answer200115MS240K259 BC++Hidden Secret

表示此题始终不知道自己错在哪里
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值