树的判定(并查集)

树的判定

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

The number of test cases will not more than 20,and the number of the node will not exceed 10000.
The inputs will be ended by a pair of -1.
输出
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8  5 3  5 2  6 4 5 6  0 0

8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

3 8  6 8  6 4 5 3  5 6  5 2  0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


代码

#include<stdio.h>
#include<string.h>
#include<cstdio>

#define MAXSIZE 10006

int father[MAXSIZE];            //父节点数组, 判断后面是否形成环
int left[MAXSIZE];              // 存放父节点
int right[MAXSIZE];             

int found(int x)                  //找到祖先         两个函数是对并查集的操作
{
	if(father[x] == -1)        
		return x;
	else
		return (found(father[x]));
}

void unionset(int x, int y)    //对父节点数组赋值
{
	father[y] = x;
}

int main()
{
	int a, b, count = 1, x, y, j;

	while(1)
	{
		memset(father, -1, sizeof(father));
		memset(left, 0, sizeof(left));
		memset(right, 0, sizeof(right));
		scanf("%d%d", &a,&b);
		if(a == -1 && b == -1)
			return 0;
		else if(a == 0 && b == 0)
			printf("Case %d is a tree.\n", count++);
		else
		{
			int i = 1;                                         //边的条数
			left[i] = a;
			right[i] = b;
			
			while(scanf("%d%d", &a, &b) && a && b)
			{
				i++;
				left[i] = a;
				right[i] = b;
			}
			int flag = 1;
			for(j = 1; j <= i; j++)
			{
				x = found(left[j]);
				y = found(right[j]);
				if(x == y || y != right[j])             //有环或者有两个入度   
				{
					flag = 0;
					break;
				}
				unionset(x, y);
			}
			if(flag)
			{                                                        //判断是否为同一颗树
				int org = found(left[1]);
				int node;                                     //节点的个数
				for(node = 2; node <= i; node++)
				{
					if(org != found(left[node]))
						break;
				}
				if(node > i)
					printf("Case %d is a tree.\n", count++);
				else
					printf("Case %d is not a tree.\n", count++);
			}
			else
				printf("Case %d is not a tree.\n", count++);
		}
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值