【Java大数】hdu 5429 Geometric Progression

Source : hdu 5429 Geometric Progression

http://acm.hdu.edu.cn/showproblem.php?pid=5429


Problem Description
Determine whether a sequence is a Geometric progression or not.
In mathematics, a geometric progression, also known as a geometric sequence, is a sequence of numbers where each term after the first is found by multiplying the previous one by a fixed, non-zero number called the common ratio. For example, the sequence 2, 6, 18, 54, … is a geometric progression with common ratio 3. Similarly 10, 5, 2.5, 1.25, … is a geometric sequence with common ratio 1/2.
Examples of a geometric sequence are powers rk of a fixed number r, such as 2k and 3k. The general form of a geometric sequence is
a, ar, ar2, ar3, ar4, …
where r ≠ 0 is the common ratio and a is a scale factor, equal to the sequence’s start value.
Input
First line contains a single integer T(T≤20) which denotes the number of test cases.
For each test case, there is an positive integer n(1≤n≤100) which denotes the length of sequence,and next line has n nonnegative numbers Ai which allow leading zero.The digit’s length of Ai no larger than 100.

Output
For each case, output “Yes” or “No”.

题意

给n个数,判断能否构成等比数列(注意数的范围)

示例

Sample Input
4
1
0
3
1 1 1
3
1 4 2
5
16 8 4 2 1
Sample Output

Yes
Yes
No
Yes


思路

大数据,我用的JAVA!


参考代码

import java.io.*;
import java.util.*;
import java.math.*;

public class Main{
    static BigInteger []a = new BigInteger [110];
    static BigInteger zero = BigInteger.ZERO;
    public static void main(String[] args){
        Scanner cin = new Scanner(System.in);
        int T = cin.nextInt();
        while(T-- >0){
            int n = cin.nextInt();
            boolean has0 = false,all0 = true;
            for(int i = 0; i < n; ++ i){
                a[i] = cin.nextBigInteger();
                if(a[i].compareTo(zero) == 0) has0 = true;
                else all0 = false;
            }
            if(all0 == true){System.out.println("Yes");continue;}
            if(has0 == true){System.out.println("No");continue;}
            boolean ok = true;
            for(int i = 2; i < n; ++ i){
                if(a[i-1].multiply(a[i-1]).equals(a[i-2].multiply(a[i])) == false)
                {
                    ok = false;
                    break;
                }
            }
            if(ok) System.out.println("Yes");
            else System.out.println("No");
        }

    }

}
  • 加粗 Ctrl + B
  • 斜体 Ctrl + I
  • 引用 Ctrl + Q
  • 插入链接 Ctrl + L
  • 插入代码 Ctrl + K
  • 插入图片 Ctrl + G
  • 提升标题 Ctrl + H
  • 有序列表 Ctrl + O
  • 无序列表 Ctrl + U
  • 横线 Ctrl + R
  • 撤销 Ctrl + Z
  • 重做 Ctrl + Y
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值