Pat(Advanced Level)Practice--1046(Shortest Distance)

Pat1046代码

题目描述:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

解题思路:对于圆形的高速路出口,无非有两种情况,
1:不跨越起点终点,例如 1->4 的路线是 1->2->3->4
2:跨越起点终点, 例如1->4 的路线是1->n->n-1>...>4
其实只需要求出其中一个距离,那么另一个距离用总和一减就OK了,然后比较两者的大小即可。
#include<cstdio>
#define MAX 100005

using namespace std;

int main(int argc,char *argv[])
{
	int n,m;
	int D[MAX];
	int i,j;
	int in,out;
	int sum=0;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&D[i]);
		sum+=D[i];
	}
	scanf("%d",&m);
	for(i=1;i<=m;i++)
	{
		int ans=0;
		scanf("%d%d",&in,&out);
		if(in>out)
		{
			int temp=in;
			in=out;
			out=temp;
		}
		for(j=in;j<out;j++)
			ans+=D[j];
		printf("%d\n",ans<sum-ans?ans:sum-ans);
	}

	return 0;
}
这个代码,最后一个case居然超时了,没办法只好用一个数组存储起点到每个中间点的距离,然后求入口出口间的距离就是O(1)的时间复杂度了。

AC代码:
#include<cstdio>
#include<cstring>
#define MAX 100005

using namespace std;

int main(int argc,char *argv[])
{
	int n,m;
	int D[MAX];
	int S[MAX];
	int i,j;
	int in,out;
	int sum=0;
	memset(S,0,sizeof(S));
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&D[i]);
		sum+=D[i];
		if(i>=2)
			S[i]=D[i-1]+S[i-1];
	}
	scanf("%d",&m);
	for(i=1;i<=m;i++)
	{
		int ans=0;
		scanf("%d%d",&in,&out);
		if(in>out)
		{
			int temp=in;
			in=out;
			out=temp;
		}
		ans=S[out]-S[in];
		printf("%d\n",ans<sum-ans?ans:sum-ans);
	}

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值