PAT (Advanced Level) 1046. Shortest Distance (20) 求环中两点之间的距离

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
为了达到O(N),输入时进行累加记录原道到每个点的单向距离,同时算出整个环的长度sum。
求点a和点b (a<b) 的距离,可以用原点到b的距离减去原点到a的距离得到单向距离len。由于有两个方向,需要输出len和sum-len较小的一个。
/*2015.7.26cyq*/
#include <iostream>
#include <vector>
#include <math.h>
using namespace std;

int main(){
	int N;
	cin>>N;
	vector<int> ivec;
	int sum=0;
	int x;
	for(int i=0;i<N;i++){
		ivec.push_back(sum);//第一个点到原点距离为0
		cin>>x;
		sum+=x;
	}
	int M;
	cin>>M;
	int a,b;
	while(M--){
		cin>>a>>b;
		a--;
		b--;
		if(a>b)
			swap(a,b);
		int len=ivec[b]-ivec[a];
		len=min(len,sum-len);
		cout<<len<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值