ZOJ 3204 Connect them Prim

 
Connect them

Time Limit: 1 Second       Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer iand computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii = 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1a2, ...ap.
Another solution B different from A is a line of q integers: b1b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br 
OR
(2) p < q and ai = bi for all 0 < i <= p


Author:  CAO, Peng

Source: The 6th Zhejiang Provincial Collegiate Programming Contest



我贴上题目的原因是因为我想更多人看到

这题很坑 坑在哪里呢?

我在寻找WA的原因时出了几组数据 其中一组是

1
10
0 1 2 3 4 5 6 7 8 9
1 0 3 2 3 4 5 6 7 8
2 3 0 1 2 3 4 5 6 7
3 2 1 0 1 2 3 4 5 6
4 3 2 1 0 1 2 3 4 5
5 4 3 2 1 0 1 2 3 4
6 5 4 3 2 1 0 1 2 3
7 6 5 4 3 2 1 0 1 2
8 7 6 5 4 3 2 1 0 1
9 8 7 6 5 4 3 2 1 0 

我的AC代码跑出来的结果是(我多输出了一个权值和来debug): 

而我的WA代码跑出来的结果是:


我的WA代码跑出来的结果的字典序比AC代码跑出来的还小! 两份代码仅一行的差距

网络上我暂时只看到一个使用prim算法并且AC了的人 这个人的代码跑我上面的那组数据同样是第二幅图的结果

而我找了几份其他人的kruskal的代码 发现是没问题的 跑出来是第一张图的结果 我在这里把两份代码都贴一下 希望有人和我交流一下


AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <queue>
#include <map>
#include <string>
#include <stack>

#define maxn 110
#define _max(a,b) ((a)>(b)?(a):(b))
#define _min(a,b) ((a)>(b)?(b):(a))

const int maxi = 1 << 30;
const int mini = 1 << 31;
const int inf = 0x3f3f3f3f;

using namespace std;
int G[maxn][maxn], low[maxn], note[maxn];
bool vis[maxn];
struct node{
    int a, b;
    bool operator < (const node &q) const{
        if(a != q.a) return a > q.a;
        return b > q.b;
    }
}a;
void prim(int n) {
    priority_queue<node> PQN;
    int cur = 1, minn, flag = 0, re = 0;
    memset(vis, 0, sizeof(vis));
    memset(note, 0, sizeof(note));
    vis[1] = 1;
    for(int i = 2; i <= n; i++) {
        low[i] = G[1][i];
        note[i] = 1;
    }
    for(int i = 2; i <= n; i++) {
        minn = inf;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && low[j] <= minn && low[j] < inf) {
                minn = low[j];
                cur = j;
            }
        }
        if(minn == inf) {
            printf("-1\n");
            return;
        }
        if(note[cur] > cur) {
            a.a = cur;
            a.b = note[cur];
        }
        else {
            a.a = note[cur];
            a.b = cur;
        }
        PQN.push(a);
        vis[cur] = 1;
        re += minn;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && G[cur][j] < low[j]) {
                low[j] = G[cur][j];
                note[j] = cur;
            }
            if(!vis[j] && G[cur][j] == low[j] && note[j] > cur) {
                low[j] = G[cur][j];
                note[j] = cur;
            }
        }
    }
    while(!PQN.empty()) {
        node t = PQN.top();
        PQN.pop();
        if(!flag) {
            printf("%d", t.a);
            flag = 1;
        }
        else printf(" %d", t.a);
        printf(" %d", t.b);
    }
    puts("");
}
int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int n;
        scanf("%d", &n);
        memset(G, 0x3f, sizeof(G));
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= n; j++) {
                int t;
                scanf("%d", &t);
                if(t) G[i][j] = t;
            }
        }
        prim(n);
    }
    return 0;
}

WA代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <queue>
#include <map>
#include <string>
#include <stack>

#define maxn 110
#define _max(a,b) ((a)>(b)?(a):(b))
#define _min(a,b) ((a)>(b)?(b):(a))

const int maxi = 1 << 30;
const int mini = 1 << 31;
const int inf = 0x3f3f3f3f;

using namespace std;
int G[maxn][maxn], low[maxn], note[maxn];
bool vis[maxn];
struct node{
    int a, b;
    bool operator < (const node &q) const{
        if(a != q.a) return a > q.a;
        return b > q.b;
    }
}a;
void prim(int n) {
    priority_queue<node> PQN;
    int cur = 1, minn, flag = 0, re = 0;
    memset(vis, 0, sizeof(vis));
    memset(note, 0, sizeof(note));
    vis[1] = 1;
    for(int i = 2; i <= n; i++) {
        low[i] = G[1][i];
        note[i] = 1;
    }
    for(int i = 2; i <= n; i++) {
        minn = inf;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && low[j] < minn) { //只有这里不同!
                minn = low[j];
                cur = j;
            }
        }
        if(minn == inf) {
            printf("-1\n");
            return;
        }
        if(note[cur] > cur) {
            a.a = cur;
            a.b = note[cur];
        }
        else {
            a.a = note[cur];
            a.b = cur;
        }
        PQN.push(a);
        vis[cur] = 1;
        re += minn;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && G[cur][j] < low[j]) {
                low[j] = G[cur][j];
                note[j] = cur;
            }
            if(!vis[j] && G[cur][j] == low[j] && note[j] > cur) {
                low[j] = G[cur][j];
                note[j] = cur;
            }
        }
    }
    while(!PQN.empty()) {
        node t = PQN.top();
        PQN.pop();
        if(!flag) {
            printf("%d", t.a);
            flag = 1;
        }
        else printf(" %d", t.a);
        printf(" %d", t.b);
    }
    puts("");
}
int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int n;
        scanf("%d", &n);
        memset(G, 0x3f, sizeof(G));
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= n; j++) {
                int t;
                scanf("%d", &t);
                if(t) G[i][j] = t;
            }
        }
        prim(n);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值