ZOJ 3204 Connect them(最小生成树:kruscal算法)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3204


Connect them

Time Limit: 1 Second     Memory Limit:32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN).All connections are two-way (that is connecting computersi andj is the same as connecting computersj and i). The cost of connecting computeri and computerj is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integerT (T <= 100), indicating the number of test cases. ThenT test cases follow.

The first line of each test case contains an integern (1 <n <= 100). Thenn lines follow, each of which containsn integers separated by a space. Thej-th integer of thei-th line in thesen lines is cij, indicating the cost of connecting computersi andj (cij = 0 means that you cannot connect them). 0 <=cij <= 60000,cij = cji,cii = 0, 1 <=i, j <=n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line.If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small")If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1
Hints:
A solution A is a line of p integers: a1, a2, ...ap.
Another solution B different from A is a line of q integers:b1,b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= p, r <=q) such thatai =bi for all 0 <i < r andar <br
OR
(2) p < q and ai = bi for all 0 <i <=p


题目大意:题目大意:有几台电脑,怎么用最少的费用把他

           们连接起来

   

解题思路:最小生成树问题。先将边从小到大排序,依次把

           边两端的点用并查集合并。需要注意的是,题目中

           给出的矩阵上三角和下三角是相同的,即只需处理

           一半就可以啦。


<span style="font-size:24px;">///知识点:最小生成树
 #include<iostream>
 #include<cstdio>
 #include<algorithm>
 #include<cstring>
 using namespace std;

 const int maxn=110;
 int f[maxn];
 struct Edge
 {
     int from,to;
     int w;
 }edge[maxn*maxn];
 int tol;
 Edge ans[maxn*maxn];
 int cnt;
 void addedge(int u,int v,int w)
 {
     edge[tol].from=u;
     edge[tol].to=v;
     edge[tol].w=w;
     tol++;
 }
 bool cmp1(Edge a,Edge b)
 {
     if(a.w!=b.w) return a.w<b.w;
     else if(a.from!=b.from) return a.from<b.from;
     else return a.to<b.to;
 }
 bool cmp2(Edge a,Edge b)
 {
     if(a.from!=b.from) return a.from<b.from;
     else return a.to<b.to;
 }
 int find(int x)
 {
     if(f[x]==-1) return x;
     return f[x]=find(f[x]);
 }
 void kruscal()
 {
     memset(f,-1,sizeof(f));
     cnt=0;
     for(int k=0;k<tol;k++)
     {
         int u=edge[k].from;
         int v=edge[k].to;
         int t1=find(u);
         int t2=find(v);
         if(t1!=t2)
         {
             ans[cnt++]=edge[k];
             f[t1]=t2;
         }
     }
 }
 int main()
 {
     int T;
     scanf("%d",&T);
     int n;
     while(T--)
     {
         scanf("%d",&n);
         tol=0;
         int w;
         for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
         {
             scanf("%d",&w);
             if(j<=i) continue;
             if(w==0) continue;
             addedge(i,j,w);
         }
         sort(edge,edge+tol,cmp1);
         kruscal();
         if(cnt!=n-1)
         {
             printf("-1\n");
             continue;
         }
         else
         {
             sort(ans,ans+cnt,cmp2);
             for(int i=0;i<cnt-1;i++)
                printf("%d %d ",ans[i].from,ans[i].to);
             printf("%d %d\n",ans[cnt-1].from,ans[cnt-1].to);
         }
     }
     return 0;
 }</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值