2014 ACMICPC Asia Regional Anshan Online G Osu!

[Problem Description]
Osu! is a famous music game that attracts a lot of people.  In osu!, there is a performance scoring 
system, which evaluates your performance. Each song you have played will have a score. And the 
system  will  sort  all  you  scores in  descending  order.  After  that,  the i-th song scored ai will add
0.95^(i-1)*ai to your total score.
Now you are given the task to write a calculator for this system.
[Input Format]
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains an integer n, denoting the number of songs you have played.
The second line contains n integers a1, a2, ..., an separated by a single space, denoting the score of 
each song.
T<=20, n<=50, 1<=ai<=500.
[Output Format]
For each test case, output one line for the answer.
Your answers will be considered correct if its absolute error is smaller than 1e-5.
[Sample Input]
1
2
530 478
[Sample Output]

984.1000000000

# include <stdio.h>
# include <math.h>
# include <algorithm>
# include <stdlib.h>
using namespace std;
int main()
{
    int T;
    int n;
    int a[1000];
    int i;
    scanf("%d",&T);
    while(T--)
    {
        double sum=0;
       scanf("%d",&n);
        for(i=0;i<n;i++)
           scanf("%d",&a[i]);
         sort(a,a+n);
      for(int i=0;i<n;i++)
           sum+=pow(0.95,i)*a[n-1-i];
      printf("%lf\n",sum);
        }



return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值