UvaLA 4670 Dominating Patterns

AC自动机,找出现最多的子串

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

Download as PDF

The archaeologists are going to decipher a very mysterious ``language". Now, they know many language patterns; each pattern can be treated as a string on English letters (only lower case). As a sub string, these patterns may appear more than one times in a large text string (also only lower case English letters).

What matters most is that which patterns are the dominating patterns. Dominating pattern is the pattern whose appearing times is not less than other patterns.

It is your job to find the dominating pattern(s) and their appearing times.

Input

The entire input contains multi cases. The first line of each case is an integer, which is the number of patterns N1$ \le$N$ \le$150. Each of the following N lines contains one pattern, whose length is in range [1, 70]. The rest of the case is one line contains a large string as the text to lookup, whose length is up to 106.

At the end of the input file, number `0' indicates the end of input file.

Output

For each of the input cases, output the appearing times of the dominating pattern(s). If there are more than one dominating pattern, output them in separate lines; and keep their input order to the output.

Sample Input

2 
aba 
bab 
ababababac 
6 
beta 
alpha 
haha 
delta 
dede 
tata 
dedeltalphahahahototatalpha 
0

Sample Output

4 
aba 
2 
alpha 
haha


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;

const int maxn=160*80;

struct WORD
{
    int id,cnt;
    char str[80];
}w[160];
int hash[maxn];
int chd[maxn][26],f[maxn],val[maxn],last[maxn],sz;

bool cmp(WORD a,WORD b)
{
    if(a.cnt!=b.cnt)
    {
        return a.cnt>b.cnt;
    }
    else
    {
        return a.id<b.id;
    }
}

void init()
{
    sz=1;
    memset(chd[0],0,sizeof(chd[0]));
    memset(f,0,sizeof(f));
    memset(val,0,sizeof(val));
    memset(last,0,sizeof(last));
}

void insert(char* p,int i)
{
    int u=0;
    for(;*p;p++)
    {
        if(chd[u][*p-'a']==0)
        {
            memset(chd[sz],0,sizeof(chd[sz]));
            chd[u][*p-'a']=sz++;
        }
        u=chd[u][*p-'a'];
    }
    val[u]++;
    hash[u]=i;
}

void getFail()
{
    queue<int> q;
    f[0]=0;
    for(int c=0;c<26;c++)
    {
        int u=chd[0][c];
        if(u)
        {
            q.push(u);
            f[u]=last[u]=0;
        }
    }
    while(!q.empty())
    {
        int r=q.front(); q.pop();
        for(int c=0;c<26;c++)
        {
            int u=chd[r][c];
            if(!u) {chd[r][c]=chd[f[r]][c];continue;}
            q.push(u);
            int v=f[r];
            while(v&&!chd[v][c]) v=f[v];
            f[u]=chd[v][c];
            last[u]=val[u]?f[u]:last[f[u]];
        }
    }
}

void solve(int j)
{
    if(!j) return ;
    int u=hash[j];
    w[u].cnt++;
}

int find(char* T)
{
    int n=strlen(T);
    int j=0;
    getFail();
    for(int i=0;i<n;i++)
    {
        j=chd[j][T[i]-'a'];
        if(val[j]) solve(j);
        else if(last[j]) solve(last[j]);
    }
}

int main()
{
    int n;
    char T[1100000];
    while(scanf("%d",&n)!=EOF&&n)
    {
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%s",w[i].str);
            w[i].id=i;
            w[i].cnt=0;
            insert(w[i].str,i);
        }
        scanf("%s",T);
        find(T);
        sort(w,w+n,cmp);
        int mxx=w[0].cnt;
        printf("%d\n",mxx);
        for(int i=0;i<n;i++)
        {
            if(w[i].cnt==mxx)
            {
                printf("%s\n",w[i].str);
            }
            else break;
        }
    }
    return 0;
}




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值