usaco - Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0,1,2,3,... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2 (where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a single line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24
本菜鸟第一次接触剪枝发现剪枝真的好神奇(代码参考网上)
/*
ID:
PROG: ariprog
LANG: C++
*/
#include<iostream>
#include<cstdio>
#include<fstream>
#include<algorithm>

using namespace std;

const int MAX_N=126000;
int N,M;
int bisquares[MAX_N]={0};

struct A{
    int aa;
    int bb;
}fina[10003];

int my(A i,A j){
	if(i.bb<j.bb)
		return 1;
	if(i.bb==j.bb) {
		if(i.aa<j.aa)
			return 1;
	}
	return 0;
}

int main(){
    freopen("ariprog.in","r",stdin);
    freopen("ariprog.out","w",stdout);
    scanf("%d%d",&N,&M);
    //把所有的双平方数对应位置的值赋为1(剪枝)
    for(int i=0;i<=M;i++){
        for(int j=0;j<=M;j++){
            bisquares[i*i+j*j]=1;
        }
    }
    int p=0,mm=2*M*M;
    for(int a=0;a<=mm;a++){//首项从0开始公差从1开始
        if(bisquares[a]){//每个数组的第一项为a+0*b=a;(剪枝)
            for(int b=1;b<mm;b++){
                if(a+b*(N-1)>mm)break;//从这就开始判断最大值是否会超出mm节省时间(剪枝)
                int h=a,l=b,k=0;
                while(bisquares[h]&&k<N){
                    k++;
                    h+=l;//从此处构造等差数列
                }
                if(k==N){
                    fina[p].aa=a;
                    fina[p].bb=b;
                    p++;
                }
            }
        }
    }
    sort(fina,fina+p,my);
    if(!p)printf("NONE\n");
    else{
        for(int i=0;i<p;i++){
            printf("%d %d\n",fina[i].aa,fina[i].bb);
        }
    }
}
刚开始时把bisquares数组从0开始每个都赋值为i*i+j*j,然后找到对应数组的每一个值和bisquares数组的每一个值比较这就大大浪费了时间,不如直接设bisquares数组元素为0,bisquares[i*i+j*j]为1,判断数组元素的值是否为双平方数时就可以直接看bisquares[数组元素值]是否为1。
还有一个巧妙的地方就是在第一个for循环时,由于每个数组的第一个元素都为a+0*b=a,所以可以先直接判断bisquares的值是否为1节省时间。
总之还要再努力加油了!!!



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值