ZOJ 3790 Consecutive Blocks

离散化+暴力


Consecutive Blocks

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There are N (1 ≤ N ≤ 105) colored blocks (numbered 1 to N from left to right) which are lined up in a row. And the i-th block's color is Ci (1 ≤ Ci ≤ 109). Now you can remove at most K (0 ≤ K ≤ N) blocks, then rearrange the blocks by their index from left to right. Please figure out the length of the largest consecutive blocks with the same color in the new blocks created by doing this.

For example, one sequence is {1 1 1 2 2 3 2 2} and K=1. We can remove the 6-th block, then we will get sequence {1 1 1 2 2 2 2}. The length of the largest consecutive blocks with the same color is 4.

Input

Input will consist of multiple test cases and each case will consist of two lines. For each test case the program has to read the integers N and K, separated by a blank, from the first line. The color of the blocks will be given in the second line of the test case, separated by a blank. The i-th integer means Ci.

Output

Please output the corresponding length of the largest consecutive blocks, one line for one case.

Sample Input
8 1
1 1 1 2 2 3 2 2
Sample Output
4

Author:  LIN, Xi
Source:  ZOJ Monthly, June 2014


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <vector>

using namespace std;

const int maxn=100100;

int n,k,c[maxn],nc,ans;
vector<int> vi[maxn];

void gaoit(int x)
{
    int sz=vi[x].size();
    if(sz<=ans) return;
    int L=0,nowsize=1;
    ans=max(ans,nowsize);
    for(int i=1;i<sz;i++)
    {
        nowsize=i-L+1;
        while(vi[x][i]-vi[x][L]+1-nowsize>k)
        {
            L++; nowsize=i-L+1;
        }
        ans=max(nowsize,ans);
    }
}

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        map<int,int> mp;
        nc=1;ans=0;
        for(int i=0;i<n;i++)
        {
            int a;
            scanf("%d",&a);
            if(mp[a]==0)   mp[a]=nc++;
            c[i]=mp[a];
            vi[i+1].clear();
        }
        for(int i=0;i<n;i++)    vi[c[i]].push_back(i);
        for(int i=1;i<nc;i++) gaoit(i);
        printf("%d\n",ans);
    }
    return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值