HDOJ 4876 ZCC loves cards


枚举组合,在不考虑连续的情况下判断是否可以覆盖L...R,对随机数据是一个很大的减枝.

通过检测的暴力计算一遍


ZCC loves cards

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1346    Accepted Submission(s): 335


Problem Description
ZCC loves playing cards. He has n magical cards and each has a number on it. He wants to choose k cards and place them around in any order to form a circle. He can choose any several  consecutive cards the number of which is m(1<=m<=k) to play a magic. The magic is simple that ZCC can get a number x=a1⊕a2...⊕am, which ai means the number on the ith card he chooses. He can play the magic infinite times, but  once he begin to play the magic, he can’t change anything in the card circle including the order.
ZCC has a lucky number L. ZCC want to obtain the number L~R by using one card circle. And if he can get other numbers which aren’t in the range [L,R], it doesn’t matter. Help him to find the maximal R.
 

Input
The input contains several test cases.The first line in each case contains three integers n, k and L(k≤n≤20,1≤k≤6,1≤L≤100). The next line contains n numbers means the numbers on the n cards. The ith number a[i] satisfies 1≤a[i]≤100.
You can assume that all the test case generated randomly.
 

Output
For each test case, output the maximal number R. And if L can’t be obtained, output 0.
 

Sample Input
  
  
4 3 1 2 3 4 5
 

Sample Output
  
  
7
Hint
⊕ means xor
 

Author
镇海中学
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4881  4880  4879  4878  4877 
 

Statistic |  Submit |  Discuss |  Note



#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int n,k,m,a[30],save[30],have[30],R,L;
bool vis[3000],cx[200];

void ckMax(int num,int sum)
{
	vis[sum]=true;
	if(num==k) return ;
	ckMax(num+1,sum^save[num]);
	ckMax(num+1,sum);
}

bool ck()
{
 	memset(vis,0,sizeof(vis));
 	ckMax(0,0);
 	for(int i=L;i<=R;i++)
 	{
 		if(vis[i]==false)	return false;
 	}
 	return true;
}

void CALU() 
{  
    if (!ck()) return;  
    for(int i=0;i<k;i++)
    	have[i]=save[i];
    do
    {
    	memset(vis,0,sizeof(vis));
    	for(int i=0;i<k;i++)
    	{
    		int x=0;
    		for(int j=0;j<k;j++)
    		{
    			x^=have[(i+j)%k];
    			vis[x]=true;	
    		}
    	}
    	for(int i=L;i<=L+k*k;i++)
    	{
    		if(vis[i]==false) break;
    		R=max(R,i);
    	}
    }while(next_permutation(have,have+k-1));
}      

void dfs(int num,int id)
{
	if(num==k)
	{
		CALU();
		return ;
	}
	for(int i=id;i<n;i++)
	{
		save[num]=a[i];
		dfs(num+1,i+1);
	}
}

int main()
{
	while(scanf("%d%d%d",&n,&k,&L)!=EOF)
	{
		R=L-1;
		for(int i=0;i<n;i++)
			scanf("%d",a+i);
		sort(a,a+n);
		dfs(0,0);
		if(R<L) printf("0\n");
		else printf("%d\n",R);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值