HDOJ 4430 Yukari's Birthday


C++高精度问题太蛋疼了....

Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2891    Accepted Submission(s): 604


Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
  
  
18 111 1111
 

Sample Output
  
  
1 17 2 10 3 10
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

typedef long long int LL;

LL n;

LL check(LL r)
{
    LL low=2,high=n,mid,ret=-1;

    while(low<=high)
    {
        mid=(low+high)/2;

        if(((LL)(pow(mid*1.,r-1.))>n||(LL)(pow(mid*1.,r-1.))<0)
           ||(LL)(pow(mid*1.,r*1.))>n||(LL)(pow(mid*1.,r*1.))<0)
        {
            high=mid-1;
            continue;
        }

        LL temp=mid*(1-(LL)(pow(mid*1.,r*1.)))/(1-mid);

        if(temp<=n-1||temp<=n)
        {
            if(temp==n||temp==n-1) ret=mid;
            low=mid+1;
        }
        else
        {
            high=mid-1;
        }
    }

    return ret;
}

int main()
{
while(scanf("%I64d",&n)!=EOF)
{
    LL R=1,K=n-1,ans=(1LL<<60);
    for(LL r=2;r<40;r++)
    {
        LL k=check(r);
        if(k==-1) continue;
        if(ans>r*k)
        {
            R=r; K=k;
        }
    }
    printf("%I64d %I64d\n",R,K);
}
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值