HDOJ 4666 Hyperspace 最大曼哈顿距离

66 篇文章 0 订阅


二进制转化,求最大曼哈顿距离....


Hyperspace

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1123    Accepted Submission(s): 530


Problem Description
The great Mr.Smith has invented a hyperspace particle generator. The device is very powerful. The device can generate a hyperspace. In the hyperspace, particle may appear and disappear randomly. At the same time a great amount of energy was generated.
However, the device is in test phase, often in a unstable state. Mr.Smith worried that it may cause an explosion while testing it. The energy of the device is related to the maximum manhattan distance among particle.
Particles may appear and disappear any time. Mr.Smith wants to know the maxmium manhattan distance among particles when particle appears or disappears.
 

Input
The input contains several test cases, terminated by EOF.
In each case: In the first line, there are two integer q(number of particle appear and disappear event, ≤60000) and k(dimensions of the hyperspace that the hyperspace the device generated, ≤5). Then follows q lines. In each line, the first integer ‘od’ represents the event: od = 0 means this is an appear
event. Then follows k integer(with absolute value less then 4 × 10 7). od = 1 means this is an disappear event. Follows a integer p represents the disappeared particle appeared in the pth event.
 

Output
Each test case should contains q lines. Each line contains a integer represents the maximum manhattan distance among paticles.
 

Sample Input
  
  
10 2 0 208 403 0 371 -180 1 2 0 1069 -192 0 418 -525 1 5 1 1 0 2754 635 0 -2491 961 0 2954 -2516
 

Sample Output
  
  
0 746 0 1456 1456 1456 0 2512 5571 8922
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>

using namespace std;

const int maxn=66000;

int n,k,id;
int mat[maxn][5];
int pos[maxn];
multiset<int> SET[50];

void init()
{
    id=0;
    int nn=1<<k;
    for(int i=0;i<nn;i++)
        SET[i].clear();
}

int getSum(int id,int x)
{
    int sum=0;
    for(int i=0;i<k;i++)
    {
        if(x&(1<<i)) sum+=mat[id][i];
        else sum-=mat[id][i];
    }
    return sum;
}

void add(int x)
{
    int nn=1<<k;
    for(int i=0;i<nn;i++)
    {
        int xx=getSum(x,i);
        SET[i].insert(xx);
    }
}

void rm(int x)
{
    int nn=1<<k;
    for(int i=0;i<nn;i++)
    {
        int xx=getSum(x,i);
        SET[i].erase(SET[i].find(xx));
    }
}

int check()
{
    int nn=1<<k;
    int ans=0;
    for(int i=0;i<nn;i++)
    {
        multiset<int>::iterator S,E;
        S=SET[i].begin();
        E=SET[i].end();
        E--;
        ans=max(ans,*E-*S);
    }
    return ans;
}

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        init();
        int kind;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&kind);
            if(kind==0)
            {
                for(int j=0;j<k;j++)
                {
                    scanf("%d",&mat[id][j]);
                }
                add(id);
                pos[i+1]=id;
                id++;
            }
            else
            {
                int rmid;
                scanf("%d",&rmid);
                rm(pos[rmid]);
            }
            printf("%d\n",check());
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值