Hyperspace HDU - 4666 (最远曼哈顿距离模板题)

The great Mr.Smith has invented a hyperspace particle generator. The device is very powerful. The device can generate a hyperspace. In the hyperspace, particle may appear and disappear randomly. At the same time a great amount of energy was generated. 
However, the device is in test phase, often in a unstable state. Mr.Smith worried that it may cause an explosion while testing it. The energy of the device is related to the maximum manhattan distance among particle. 
Particles may appear and disappear any time. Mr.Smith wants to know the maxmium manhattan distance among particles when particle appears or disappears.

Input

The input contains several test cases, terminated by EOF. 
In each case: In the first line, there are two integer q(number of particle appear and disappear event, ≤60000) and k(dimensions of the hyperspace that the hyperspace the device generated, ≤5). Then follows q lines. In each line, the first integer ‘od’ represents the event: od = 0 means this is an appear 
event. Then follows k integer(with absolute value less then 4 × 10 7). od = 1 means this is an disappear event. Follows a integer p represents the disappeared particle appeared in the pth event.

Output

Each test case should contains q lines. Each line contains a integer represents the maximum manhattan distance among paticles.

Sample Input

10 2
0 208 403
0 371 -180
1 2
0 1069 -192
0 418 -525
1 5
1 1
0 2754 635
0 -2491 961
0 2954 -2516

Sample Output

0
746
0
1456
1456
1456
0
2512
5571
8922

思路:和今年多校赛的一题很像,之前也分析过做法(二进制枚举加减法)。这题区别在于它是以查询的形式询问的,所以需要用set来记录之前已经计算过的(需要用multiset,允许重复的)。

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+9;
const int mod=1e9+7;
#define inf 0x3f3f3f3f
int q,k;
multiset<int> se[1<<5];
int a[maxn][10];
int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    while(scanf("%d%d",&q,&k)!=EOF)
    {
        for(int i=0;i<(1<<k);i++)
        {
            se[i].clear();
        }
        int op,x;
        for(int i=1;i<=q;i++)
        {
            scanf("%d",&op);
            if(op==0)
            {
                for(int j=0;j<k;j++)
                {
                    scanf("%d",&a[i][j]);
                }
                for(int j=0;j<(1<<k);j++)
                {
                    int s=0;
                    for(int t=0;t<k;t++)
                    {
                        if(j&(1<<t))
                        {
                            s+=a[i][t];
                        }
                        else
                        {
                            s-=a[i][t];
                        }
                    }
                    se[j].insert(s);
                }
            }
            else
            {
                scanf("%d",&x);//对于删除点,需要去除每个和它有关的状态
                for(int j=0;j<(1<<k);j++)
                {
                    int s=0;
                    for(int t=0;t<k;t++)
                    {
                        if(j&(1<<t))
                        {
                            s+=a[x][t];
                        }
                        else
                        {
                            s-=a[x][t];
                        }
                    }
                    multiset<int>::iterator it=se[j].find(s);
                    se[j].erase(it);
                }
            }
            int ans=0;
            for(int j=0;j<(1<<k);j++)
            {
                multiset<int>::iterator it=se[j].end();
                it--;
                int t1=*(it);
                it=se[j].begin();
                int t2=*it;
                ans=max(ans,t1-t2);
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值