HDOJ 2802 F(N)


循环节4018

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3542    Accepted Submission(s): 1219


Problem Description

Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
  
  
1 2 3 0
 

Sample Output
  
  
1 7 20
 

Source
 



/* ***********************************************
Author        :CKboss
Created Time  :2014年12月14日 星期日 12时29分33秒
File Name     :HDOJ2802.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <cmath>

using namespace std;

const int mod=2009;

int f[5000];

int Get(int x)
{
	int part1=((x*x)%mod*x)%mod;
	int y=x-1;
	int part2=((y*y)%mod*y)%mod;
	return ((f[x-2]+part1)%mod+mod-part2)%mod;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int n;
	f[1]=1; f[2]=7;
	for(int i=3;i<=4018;i++) f[i]=Get(i);

	while(scanf("%d",&n)!=EOF&&n)
	{
		n=n%4018;
		if(n==0) puts("0");
		else printf("%d\n",f[n]);
	}

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值