HDU 2802 F(N)

44 篇文章 0 订阅
12 篇文章 0 订阅

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4531    Accepted Submission(s): 1585


Problem Description

Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
  
  
1 2 3 0
 

Sample Output
  
  
1 7 20
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2807  2804  2800  2806  2808 
打表法找出循环节,一个新的技巧。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
__int64 f[110000];
void  init()
{
	int i;
	f[1]=1;
	f[2]=7;
	for(i=3;i<=5000;i++)
	f[i]=(f[i-2]+3*i*i-3*i+1)%2009;
}
int main()
{
	__int64 n,i;
	init();
	while(scanf("%I64d",&n),n)
	{
		//for(i=3;i<=110000;i=i+2)打表法找出循环节 
		//if(f[i]==1)
		//break;
		//printf("%I64d\n",i-1);
		//for(i=4;i<=110000;i=i+2)
		//if(f[i]==7)
		//break;
		//printf("%I64d\n",i-2);
	    //printf("%I64d\n",f[4018]);
		printf("%I64d\n",f[n%4018]);
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值