HDOJ 5207 Greatest Greatest Common Divisor 暴力枚举

66 篇文章 0 订阅


暴力枚举公约数,有两个数是这个公约数倍数的就可以

Greatest Greatest Common Divisor

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 395    Accepted Submission(s): 171


Problem Description
Pick two numbers  ai,aj(ij)  from a sequence to maximize the value of their greatest common divisor.
 

Input
Multiple test cases. In the first line there is an integer  T , indicating the number of test cases. For each test cases, the first line contains an integer  n , the size of the sequence. Next line contains  n  numbers, from  a1  to  an 1T100,2n105,1ai105 . The case for  n104  is no more than  10 .
 

Output
For each test case, output one line. The output format is Case # x ans x  is the case number, starting from  1 ans  is the maximum value of greatest common divisor.
 

Sample Input
  
  
2 4 1 2 3 4 3 3 6 9
 

Sample Output
  
  
Case #1: 2 Case #2: 3
 

Source
 




/* ***********************************************
Author        :CKboss
Created Time  :2015年04月18日 星期六 19时04分39秒
File Name     :B.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=100100;

int n;
int a[maxn];
int vis[maxn];

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int T_T,cas=1;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d",&n);
		int mx=0,ans=-1;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++) 
		{
			scanf("%d",a+i);
			mx=max(mx,a[i]);
			vis[a[i]]++;
		}
		for(int i=mx;i>=1;i--)
		{
			if(ans>0) break;
			int temp=0;
			for(int j=i;j<=mx;j+=i) temp+=vis[j];
			if(temp>=2) ans=i;
		}
		printf("Case #%d: %d\n",cas++,ans);
	}
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值