hdu 5207(数论+枚举)

Greatest Greatest Common Divisor

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
Pick two numbers ai,aj(ij) from a sequence to maximize the value of their greatest common divisor.
 

Input
Multiple test cases. In the first line there is an integer T , indicating the number of test cases. For each test cases, the first line contains an integer n , the size of the sequence. Next line contains n numbers, from a1 to an . 1T100,2n105,1ai105 . The case for n104 is no more than 10 .
 

Output
For each test case, output one line. The output format is Case # x : ans , x is the case number, starting from 1 , ans is the maximum value of greatest common divisor.
 

Sample Input
  
  
2 4 1 2 3 4 3 3 6 9
 

Sample Output
  
  
Case #1: 2 Case #2: 3
解题思路:cnt[i]记录因子为i的数的个数,接下来枚举i,找到最大的i使得cnt[i] >= 2即可。最开始用set超时了。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

const int maxn = 100005;
int n,cnt[maxn];

int main()
{
	int t,a,m,cas = 1;
	scanf("%d",&t);
	while(t--)
	{
		memset(cnt,0,sizeof(cnt));
		scanf("%d",&n);
		m = 0;
		for(int i = 1; i <= n; i++)
		{
			scanf("%d",&a);
			m = max(m,a);
			int k = sqrt(a + 0.5);
			for(int j = 1; j <= k; j++)
				if(a % j == 0)
				{
					cnt[j]++;
					cnt[a/j]++;
				}
			if(k * k == a)
				cnt[k]--;
		}
		for(int i = m; i >= 1; i--)
			if(cnt[i] >= 2)
			{
				printf("Case #%d: %d\n",cas++,i);
				break;
			}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值