UVa536 Tree Recovery

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Description

Download as PDF

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification 

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD

Sample Output 

ACBFGED
CDAB

分析:

先序遍历的第一个值是根节点,利用这个与中序遍历结合建树。后序遍历递归输出。

代码:

#include <cstdio>
#include <cstring>

const int maxn = 30;

char s[maxn];
int pre_order[maxn], in_order[maxn];
int left[maxn], right[maxn];

int build(int L1, int R1, int L2, int R2) {
	if (L1 > R1) return 0;
	int root = pre_order[L1], p = L2;
	while (in_order[p] != root) p++;
	int cnt = p - L2;
	left[root] = build(L1 + 1, L1 + cnt, L2, L2 + cnt - 1);
	right[root] = build(L1 + cnt + 1, R1, L2 + cnt + 1, R2);
	return root;
}

void postSearch(int u) {
	if (u == 0) return;
	postSearch(left[u]);
	postSearch(right[u]);
	printf("%c", u + 'A' - 1);
}

int main() {
	while (~scanf("%s", s)) {
		int n = strlen(s);
		for (int i = 1; i <= n; i++) pre_order[i] = s[i - 1] - 'A' + 1;
		scanf("%s", s);
		for (int i = 1; i <= n; i++) in_order[i] = s[i - 1] - 'A' + 1;
		memset(left, 0, sizeof(left));
		memset(right, 0, sizeof(right));
		int root = build(1, n, 1, n);
		postSearch(root);
		puts("");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值