N!

N!

描述

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

输入

One N in one line, process to the end of file.

输出

For each N, output N! in one line.

样例输入

123

样例输出

126

下面是代码;

 
  
#include<stdio.h>
int main()
{
    int a[10000];
    int i,j,c,m,n;
    while(scanf("%d",&n)!=EOF){
    a[0]=1;
    m=0; 
    for(i=1;i<=n;i++)
    { 
        c=0; 
        for(j=0;j<=m;j++)
        { 
        a[j]=a[j]*i+c; 
        c=a[j]/10000; 
        a[j]=a[j]%10000; 
        } 
    if(c>0) {m++;a[m]=c;} 
    } 
    printf("%d",a[m]); 
    for(i=m-1;i>=0;i--) printf("%4.4d",a[i]);
    printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值