N! (HDU - 1042 )(大数+万进制)

N! (HDU - 1042 )(大数+万进制)

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! 

Input

One N in one line, process to the end of file. 

Output

For each N, output N! in one line. 

Sample Input

1
2
3

Sample Output

1
2
6

思路:这道题是求10000以内的阶乘,很明显是个大数,所以我们在这里用到万进制,万进制顾名思义就是逢10000进1,用万进制算的话,求结果比较方便。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i,j,sum,digits=1;//10000进制的位数
        int a[10001]={1};
        for(i=2; i<=n; i++)
        {
            sum=0;//进位
            for(j=0; j<digits; j++)
            {
                a[j]=a[j]*i+sum;
                sum=a[j]/10000;
                a[j]%=10000;
            }
            if(sum>0)//最高位的进位
                a[digits++]=sum;
        }
        //输出高位原样输出,低位的高位补0,一位一补
        printf("%d",a[digits-1]);
        for(i=digits-2; i>=0; i--)
            printf("%04d", a[i]);
        printf("\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值