POJ 3663 Costume Party (二分查找)

Description

It's Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of S (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input
* Line 1: Two space-separated integers: N and S
* Lines 2..N+1: Line i+1 contains a single integer: Li

Output 
* Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input
4 6
3
5
2
1
Sample Output

4


解析:

问题:求n个数字中,有多少组两个数字之和<=s。

先将数字排序,然后二分查找最后一个<=s的位置k。然后从2-k进行枚举,对应每个i再二分查找最后一个<=s-value[i]的位置p。基于排序,使得<=p的位置的数字与value[i]的和也满足<=s,再answer上累加p。统计answer。n<=20000,时间复杂度O(nlogn)。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <set>
#include <climits>
#include <cmath>
#include <algorithm>
#define MAXN 10010
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int a[MAXN];

int Bin_Search(const int *a, int low, int high, const int &key)
{
    int mid = (low + high + 1) >> 1;
    while(low < high) {
        if (a[mid] <= key) {
            low = mid;
            mid = (low + high + 1) >> 1;
        } else {
            high = mid - 1;
            mid = (low + high + 1) >> 1;
        }
    }
    return mid;
}

int cmp(const void *a, const void *b)
{
    return *(int *)a - *(int *)b;
}

int main()
{
    int n, s, k, p, ans;
    while(~scanf("%d%d", &n, &s)) {
        for(int i=0; i<n; i++) scanf("%d", &a[i]);
        qsort(a, n, sizeof(int), cmp);
        ans = 0;
        k = Bin_Search(a, 0, n-1, s);
        for(int i=1; i<=k; i++) {
            p = Bin_Search(a, 0, i-1, s-a[i]);
            if(p != -1) ans += p+1;
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值