POJ 3627 Bookshelf (贪心)

Description
Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.
Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤ Hi ≤ 10,000) and a total height summed across all N cows of S. The bookshelf has a height of B (1 ≤ B ≤ S < 2,000,000,007).
To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

Input
* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output
* Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

Sample Input
6 40
6
18
11
13
19
11
Sample Output

3


解析: (水水更健康)

问题:已知有n个人及每个人的身高,问为了达到高度b,最少需要几个人叠罗汉。保证n个人的总身高超过b。

思路:先取身高最高的,如果不足b,再取剩下中最高的。先排序,再贪心。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <set>
#include <climits>
#include <cmath>
#include <algorithm>
#define MAXN 50010
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int a[MAXN], n, m;

int cmp(const void *a, const void *b)
{
    return *(int *)a - *(int *)b;
}

int main()
{
    while(~scanf("%d %d", &n, &m)) {
        for(int i=0; i<n; i++) scanf("%d", &a[i]);
        qsort(a, n, sizeof(int), cmp);
        for(int i=n-1; i>=0; i--) {
            m -= a[i];
            if(m <= 0) {
                printf("%d\n", n-i);
                break;
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值