POJ---3628 Bookshelf 2【01背包】

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total h

Sample Input

5 16
3
1
3
5
6

Sample Output

1

SOURCE:点击打开链接


题意:有一个架子和n多头牛,架子很高需要许多牛摞起来总高度不低于架子高度时才能吃到上面的食物,问牛能吃到食物是他们的身高之和与架子差值的最小值。


解析:dp[i]表示总高度不超过i时所能达到的最大高度,将所有的高度算出来后从后向前遍历,直到找到第一个小于num即可。


代码:

#include <stdio.h>
#include <iostream>
#include <string.h>
#define MAXN 21000000
using namespace std;

int n,b,sum,k;
int dp[MAXN],h[25];

int main(void)
{
    sum=0;
    memset(h,0,sizeof(h));
    scanf("%d%d",&n,&b);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&h[i]);
        sum+=h[i];
    }
    for(int i=0; i<n; i++)
        for(int j=sum; j>=h[i]; j--)
            dp[j]=max(dp[j],dp[j-h[i]]+h[i]);
    for(int i=sum; i>=0; i--)
        if(dp[i]<b)
        {
            k=++i;
            break;
        }
    printf("%d\n",dp[k]-b);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值