POJ2828 Buy Tickets 【线段树】+【单点更新】+【逆序】

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 12296 Accepted: 6071

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source



同样的代码,选择不同的编译器运行时间直接是倍数关系。。

Run IDUserProblemResultMemoryTimeLanguageCode LengthSubmit Time
13039660changmu2828Accepted4536K1375MSC++953B2014-07-08 00:09:31
13039659changmu2828Accepted4764K3391MSG++953B2014-07-08 00:08:47

这题折腾了好久,线段树节点保存的是区间空余线段的数量,由于区间是右开的,所以也可以看作是左端点空闲数量,update函数确定插入区间并更新空闲元素数量(即线段树节点的值),最关键的是在读取完节点后需要逆序插入,比如逆序读取pos, val后说明该点需要插入的位置前面有pos个空位,缕清思路后就该coding了~~

#include <stdio.h>
#define maxn 200002
#define lson l, mid, rt << 1
#define rson mid, r, rt << 1 | 1

struct Node{
	int pos, val;
} arr[maxn];
int tree[maxn << 2], ans[maxn];

void build(int l, int r, int rt)
{
	tree[rt] = r - l;
	if(tree[rt] == 1) return;
	
	int mid = (l + r) >> 1;
	build(lson);
	build(rson);
}

void update(int pos, int val, int l, int r, int rt)
{
	--tree[rt];
	if(r - l == 1){
		ans[l] = val; return;
	}
	
	int mid = (l + r) >> 1;
	if(tree[rt << 1] > pos) update(pos, val, lson);
	else update(pos - tree[rt << 1], val, rson);
}

int main()
{
	int n, pos, val, i;
	while(scanf("%d", &n) == 1){
		for(i = 0; i < n; ++i)
			scanf("%d%d", &arr[i].pos, &arr[i].val);
			
		build(0, n, 1); //注意右端点,线段树存储的是线段信息
		
		for(i = n - 1; i >= 0; --i)
			update(arr[i].pos, arr[i].val, 0, n, 1);
			
		for(i = 0; i < n; ++i)
			printf("%d%c", ans[i], i != (n - 1) ? ' ' : '\n');
		
	}
	return 0;
}


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值