POJ 2828-Buy Tickets-线段树区间和+逆序遍历

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

题目大意:

开始有个空队列,陆续有人进入队列,但他们会插队,给定每个人进入队列时位置和此人的权值。输出最终每个位置的权值。

核心思想:

由于后面的人会插队,前面的人不会影响后面的人的位置,逆序遍历每个人,他的位置可以立即确定下来,则此位置被占(体现在线段树上就是此位置的值由1变为0)并将权值,前面入队的人在计算位置的时候不将此位置计算在内(体现在线段树上就是找第k个有效值)。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=2e5+20;
int b[N];
struct Node
{
	int x,v;
} a[N];
struct node
{
	int l,r,sum;
} tr[N<<2];
void pushup(int m)
{
	tr[m].sum=tr[m<<1].sum+tr[m<<1|1].sum;
	return;
}
void build(int m,int l,int r)
{
	tr[m].l=l;
	tr[m].r=r;
	tr[m].sum=r-l+1;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	build(m<<1,l,mid);
	build(m<<1|1,mid+1,r);
	return;
}
int query(int m,int k)
{
	if(tr[m].l==tr[m].r)
	{
		tr[m].sum=0;
		return tr[m].l;
	}
	int re;
	if(tr[m<<1].sum>=k)
		re=query(m<<1,k);
	else
		re=query(m<<1|1,k-tr[m<<1].sum);
	pushup(m);
	return re;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		build(1,1,n);
		for(int i=1; i<=n; i++)
		{
			scanf("%d%d",&a[i].x,&a[i].v);
			a[i].x++;
		}
		for(int i=n; i>0; i--)
			b[query(1,a[i].x)]=a[i].v;
		for(int i=1; i<n; i++)
			printf("%d ",b[i]);
		printf("%d\n",b[n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值