HDU1495 非常可乐 【BFS】

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4832    Accepted Submission(s): 1944


Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
  
  
7 4 3 4 1 3 0 0 0
 

Sample Output
  
  
NO 3
 
跟南阳OJ的三个水杯题略像。

#include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 102
using std::queue;

int s, n, m;
bool vis[maxn][maxn][maxn];
struct Node{
	int a[3], step;
} cup;

bool del(Node& tmp, int from, int to)
{
	if(!tmp.a[from] || tmp.a[to] == cup.a[to]) return 0;
	int t = tmp.a[from] + tmp.a[to];
	if(t >= cup.a[to]){
		tmp.a[to] = cup.a[to];
		tmp.a[from] = t - cup.a[to];
	}else{
		tmp.a[to] = t;
		tmp.a[from] = 0;
	}
	if(vis[tmp.a[0]][tmp.a[1]][tmp.a[2]]) return 0;
	return vis[tmp.a[0]][tmp.a[1]][tmp.a[2]] = 1;
}

void BFS()
{
	queue<Node> Q;
	int i, j;
	Node now, tmp;
	now.a[0] = s << 1; now.a[1] = now.a[2] = 0;
	now.step = 0;
	Q.push(now);
	while(!Q.empty()){
		now = Q.front(); Q.pop();
		for(i = 0; i < 3; ++i){
			for(j = 0; j < 3; ++j){
				if(i != j){
					tmp = now;
					++tmp.step;
					if(del(tmp, i, j)){
						if(tmp.a[0] == s && tmp.a[1] == s || tmp.a[0] == s && tmp.a[2] == s || tmp.a[1] == s && tmp.a[2] == s){
							printf("%d\n", tmp.step); return;
						}
						Q.push(tmp);
					}
				}
			}
		}
	}
	printf("NO\n");
}

int main()
{
	while(scanf("%d%d%d", &s, &n, &m), s||n||m){		
		if(s & 1){
			printf("NO\n"); continue;
		}
		memset(vis, 0, sizeof(vis));
		cup.a[0] = s; cup.a[1] = n, cup.a[2] = m;
		s >>= 1; BFS();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值