[并查集]How Many Tables

并查集的定义查看这里
http://blog.csdn.net/tlonline/article/details/45587597
X - How Many Tables
Time Limit:1000MS Memory Limit:32768KB

Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

题意:给出n个人,他们之间有互相认识的关系,没有认识的人不会在同一张桌子上吃饭。求出需要的桌子数量。

标准的并查集,把相应有联系的人用union联系起来,联系完后,查询有多少个不同的集合。

#include<iostream>
#include<cstring>
#include <cstdio>
using namespace std;

int pre[1005];
bool t[1005];
int find(int x)
{
    if (pre[x] != x)
        pre[x] = find(pre[x]);
    return pre[x];
}

void Union(int x,int y)
{
    int fx = find(x),fy = find(y);
    if (fx != fy)
        pre[fx] = fy;
}
int main()
{
    int T,N,M;
    int a,b;
    cin>>T;
    while(T--)
    {
        cin>>N>>M;

        for(int i = 1; i<=N; i++)
        {    pre[i] = i;}

        for(int i =1;i<=M;i++)
        {
            cin>>a>>b;
            Union(a,b);
        }

        memset(t,0,sizeof(t));
        for(int i = 1; i<=N;i++)
        {
            t[find(i)]=1;
        }
        int ans = 0;
        for(int i =1;i<=N;i++)
            if (t[i]) ans++;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值