[线段树] POJ 3264 balanced lineup

Balanced Lineup

Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 33267
Accepted: 15615
Case Time Limit: 2000MS
Description
For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N andQ.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cowi
Lines N+2..N+Q+1: Two integers A and B (1 ≤A ≤B ≤N), representing the range of cows from A toB inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0

给定Q(1~200000)个数a1,a2,…aQ,多次求任意区间内Ai-Aj最大数和最小数的差。
本题需要维护的是最大数和最小数,每次查询时将当前最大数和最小数保存进入全局变量,再计算最大数和最小数的差。
本题树节点结构:

struct node
{
int L,R; //区间起点和终点
int minV,maxV; //本区间里的最大值和最小值
}

我写线段树一般不用左右节点指针,用一个数组存放线段树比较简单。根节点下标为0。假设线段树上某个节点的下标为i,则:
左子节点下标为i*2+1,右子节点下标为i*2+2。
用一维数组存放线段树,且根节点区间为[1,n]时,一般数组的大小需要 2 * 2^(log2N)-1 <= 4n-1,实际运用时常常可以更小,可以取3n

简单线段树问题,掌握了线段树的基本做法就比较容易想了,第一次提交代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
const int INF=0xffffff;
int minV=INF;
int maxV=-INF;

struct node{
int L,R;
int minV,maxV;
};
node tree[1000010];

void build(int root,int L,int R)
{
        tree[root].L=L;
        tree[root].R=R;
        tree[root].minV=INF;
        tree[root].maxV=-INF;
    if(L==R) return ;
    else
    {
        build(2*root,L,(L+R)/2);
        build(2*root+1,(L+R)/2+1,R);
    }
}

void insert (int root,int i,int v)
//将第i个数,其值为v,插入线段树
{
    if (tree[root].L==tree[root].R)
    {
        tree[root].minV=tree[root].maxV=v;
        return ;
    }
    tree[root].minV=min(tree[root].minV,v);
    tree[root].maxV=max(tree[root].maxV,v);
    if(i<=(tree[root].L+tree[root].R)/2)
        insert(root*2,i,v);
    else
        insert(root*2+1,i,v);
}

void query(int root,int s,int e)
//查询区间[s,e]中的最小值和最大值,如果更优就记在全局变量里
{
    if(tree[root].minV>=minV && tree[root].maxV<=maxV)
    return ;
    if(tree[root].L==s && tree[root].R==e)
    {
        maxV=max(tree[root].maxV,maxV);
        minV=min(tree[root].minV,minV);
        return;
    }
    if (e<=(tree[root].L+tree[root].R)/2)
        query(root*2,s,e);
    else if (s>(tree[root].L+tree[root].R)/2)
        query(root*2+1,s,e);
    else
     {
        query(root*2,s,(tree[root].L+tree[root].R)/2);
        query(root*2+1,(tree[root].L+tree[root].R)/2+1,e);
    }
}
int main()
{
    int N,T,h;
    scanf("%d%d",&N,&T);
    build(1,1,N);
    for (int i=1;i<=N;i++)
    {
        scanf("%d",&h);
        insert(1,i,h);
    }
    for (int i=1;i<=T;i++)
    {
        int s,e;
        scanf("%d%d",&s,&e);
        minV=INF;
        maxV=-INF;
        query(1,s,e);
        cout<<maxV-minV<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值