[模拟] 多校联合第四场 HDU5327 Olympad

Olympiad

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 272 Accepted Submission(s): 203

Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b). Please be fast to get the gold medal!

Input
The first line of the input is a single integer T (T≤1000), indicating the number of testcases.

For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1≤a≤b≤100000.

Output
For each testcase, print one line indicating the answer.

Sample Input
2
1 10
1 1000

Sample Output
10
738

Author
XJZX

给定区间L,R,询问其中每个数字位均不重复的数字有多少个。

简单题,预处理一遍,sum[n]值记下从1~n总共有多少个,相减即可。

#include <iostream>
#include<cstring>
#include <cstdio>
using namespace std;
int sum[100050];
int a[10];
bool check(int x)
{
    memset(a,0,sizeof a);
    while(x)
    {
        int temp = x % 10;
        if (a[temp]) return false;
        a[temp] = true;
        x /= 10;
    }
    return true;
}

void init()
{
    sum[0] = 0;
    for(int i =1;i<100001;i++)
    {
        sum[i] += sum[i-1];
        if (check(i))
            sum[i]++;
    }
}

int main()
{
    init();
    int T,L,R;
    cin>>T;
    while(T--)
    {
        scanf("%d%d",&L,&R);
        printf("%d\n",sum[R]-sum[L-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值