第k最短路A*启发式搜索

Remmarguts' Date
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 21549 Accepted: 5862

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story. 

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission." 

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)" 

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help! 

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate. 

Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T. 

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).

Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2

Sample Output

14
#include"stdio.h"
#include"string.h"
#include"iostream"
#include"map"
#include"string"
#include"queue"
#include"stdlib.h"
#include"algorithm"
#include"math.h"
#define M 1009
#define eps 1e-10
#define inf 100000000
#define mod 100000000
#define INF 0x3f3f3f3f
using namespace std;
struct Lnode
{
    int u,v,w,next;
}edge[M*300];
int t,head[M],h[M],num[M],use[M];
void init()
{
    t=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v,int w)
{
    edge[t].u=u;
    edge[t].v=v;
    edge[t].w=w;
    edge[t].next=head[u];
    head[u]=t++;
}
void dijstra(int n,int s)
{
    int i,j;
    memset(use,0,sizeof(use));
    memset(h,INF,sizeof(h));
    h[s]=0;
    for(i=1;i<=n;i++)
    {
        int mini=INF;
        int tep=-1;
        for(j=1;j<=n;j++)
        {
            if(!use[j]&&h[j]<mini)
            {
                mini=h[j];
                tep=j;
            }
        }
        if(tep==-1)break;
        use[tep]=1;
        for(j=head[tep];j!=-1;j=edge[j].next)
        {
            int v=edge[j].v;
            if(h[v]>h[tep]+edge[j].w)
                h[v]=h[tep]+edge[j].w;
        }
    }
}
struct node
{
    int v,g,h;
    friend bool operator<(node a,node b)
    {
        return a.g+a.h>b.g+b.h;
    }
};
int bfs(int n,int s,int t,int k)
{
    int i;
    priority_queue<node>q;
    memset(num,0,sizeof(num));
    node cur;
    cur.v=s;
    cur.g=0;
    cur.h=h[s];
    q.push(cur);
    while(!q.empty())
    {
        cur=q.top();
        q.pop();
        num[cur.v]++;
        if(num[cur.v]>k)continue;
        if(num[t]==k&&t==cur.v)return cur.g;
        for(i=head[cur.v];i!=-1;i=edge[i].next)
        {
            int v=edge[i].v;
            node now;
            now.v=v;
            now.g=cur.g+edge[i].w;
            now.h=h[v];
            q.push(now);
        }
    }
    return -1;
}
struct line
{
    int a,b,c;
}e[M*300];
int main()
{
    int n,m,i,start,endl,k;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        init();
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&e[i].a,&e[i].b,&e[i].c);
            add(e[i].b,e[i].a,e[i].c);
        }
        scanf("%d%d%d",&start,&endl,&k);
        if(start==endl)k++;//注意的地方
        dijstra(n,endl);
        init();
        for(i=1;i<=m;i++)
            add(e[i].a,e[i].b,e[i].c);
        int ans=bfs(n,start,endl,k);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值