2-sat按照最小字典序输出可行解(hdu1814)

Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2030    Accepted Submission(s): 589


Problem Description
The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.
The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.
Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .
Task
Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.
 
Input
In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.
 
Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.
 

Sample Input
  
  
3 2 1 3 2 4
 

Sample Output
  
  
1 4 5
题意:有n对夫妻,每对夫妻编号是2*i-1和2*i,然后给出m对矛盾关系,问从每对夫妻中挑选出一个人形成一个n的集合保证这n个人两两之间没有矛盾,若存在解则输出一组字典序最小的可行解?
分析:首先根据矛盾关系建图(不多说),然后dfs暴力枚举,距离做法:
首先把2n个点标记为无色,然后从第一个点开始枚举,对于当前点i如果已经染过颜色则继续,否则dfs改点,对于搜到的点,若是无色可先把其染成红色(表示选取改点),把对应的i^1染成蓝色(表示抛弃的点),如果搜到的点是红色,表示可行,如果搜到的点是蓝色,则表示i点不成功,然后把刚才搜到的点还原成无色,接着对其对立点i^1进行dfs,若可行,则接续枚举,否则不存在可行解,最后暴力出来的标记为红色的点即为字典序最小的可行解.
#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#include"queue"
#include"algorithm"
#include"string.h"
#include"string"
#include"map"
#define inf 0x3f3f3f3f
#define M 16009
using namespace std;
struct node
{
    int u,v,next;
}edge[M*20];
int t,head[M],s[M],color[M],cnt;
void init()
{
    t=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    edge[t].v=v;
    edge[t].next=head[u];
    head[u]=t++;
}
int dfs(int u)
{
    if(color[u]==1)
        return 1;
    if(color[u]==-1)
        return 0;
    s[cnt++]=u;
    color[u]=1;
    color[u^1]=-1;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(!dfs(v))
            return 0;
    }
    return 1;
}
int psq(int n)
{
    memset(color,0,sizeof(color));
    for(int i=0;i<2*n;i++)
    {
        if(color[i])continue;
        cnt=0;
        if(!dfs(i))
        {
            for(int j=0;j<cnt;j++)
                color[s[j]]=color[s[j]^1]=0;
            if(!dfs(i^1))
                return 0;
        }
    }
    return 1;
}
int main()
{
    int n,m,i;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        init();
        for(i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            a--;
            b--;
            add(a,b^1);
            add(b,a^1);
        }
        if(psq(n))
        {
            for(i=0;i<2*n;i++)
                if(color[i]==1)
                printf("%d\n",i+1);
        }
        else
            printf("NIE\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值