HDU 2054 A == B ?(找小数点)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2054

 

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input 

1 2

2 2

3 3

4 3

Sample Output 

NO

YES

YES

NO

 

思路:

此题关键是找小数点,找到小数点把最后面无效的零去掉再比较就OK;

代码如下:

#include <cstdio>
#include <cstring>
char a[100017], b[100017];
void re(char s[])
{
    int len = strlen(s);
    int p = 0;
    for(int i = 0; i < len; i++)
    {
        if(s[i] == '.')
        {
            p = 1;
            break;
        }
    }
    if(p)
    {
        for(int i = len-1; i >= 0; i--)
        {
            if(s[i] == '0')
                s[i] = '\0';
            else
                break;
            len--;
        }
        if(s[len-1] == '.')
            s[len-1] = '\0';
    }
}
int main()
{
    while(~scanf("%s%s",a,b))
    {
        re(a);
       // printf("%s\n",a);
        re(b);
       // printf("%s\n",b);
        if(strcmp(a,b))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

 

评论 10
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值