HDU4985&&bestcoder #7 1001 Little Pony and Permutation(水题)

Little Pony and Permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 66    Accepted Submission(s): 51

点击打开题目链接
Problem Description

As a unicorn, the ability of using magic is the distinguishing feature among other kind of pony. Being familiar with composition and decomposition is the fundamental course for a young unicorn. Twilight Sparkle is interested in the decomposition of permutations. A permutation of a set S = {1, 2, ..., n} is a bijection from S to itself. In the great magician —— Cauchy's two-line notation, one lists the elements of set S in the first row, and then for each element, writes its image under the permutation below it in the second row. For instance, a permutation of set {1, 2, 3, 4, 5} σ can be written as:


Here σ(1) = 2, σ(2) = 5, σ(3) = 4, σ(4) = 3, and σ(5) = 1.
Twilight Sparkle is going to decompose the permutation into some disjoint cycles. For instance, the above permutation can be rewritten as:


Help Twilight Sparkle find the lexicographic smallest solution. (Only considering numbers).
 

Input
Input contains multiple test cases (less than 10). For each test case, the first line contains one number n (1\(\leq\)n\(\leq\)\(10^5\)). The second line contains n numbers which the i-th of them(start from 1) is σ(i).
 

Output
For each case, output the corresponding result.
 

Sample Input
  
  
5 2 5 4 3 1 3 1 2 3
 

Sample Output
  
  
(1 2 5)(3 4) (1)(2)(3)
 

Source
BestCoder Round #7

暴力解决了,~~~~(>_<)~~~~ 

卡在题意上了,先看了一下置换群的定义;渣爆了......

代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
#define N 100010
using namespace std;
int a[N];
bool visit[N];
int main()
{
    int n,i,j,k;
    while(~scanf("%d",&n))
    {
    memset(visit,0,sizeof(visit));
    memset(a,0,sizeof(a));
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1; i<=n; i++)
        {
            if(!visit[i])
            {
                printf("(%d",i);
                visit[i]=1;
                for(j=a[i]; j<=n; j=a[j])
                {
                    if(visit[j])
                        break;
                    printf(" %d",j);
                    visit[j]=1;
                }
                printf(")");
            }
        }
        printf("\n");
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值