HDU 1050 Moving Tables 贪心!!

Moving Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26685 Accepted Submission(s): 8840

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output
The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output
10
20
30

系统的学习贪心,这个算是第一个题吧,只要找到经过最多的房间号就可以了,这题和HDU1800本质应该是一样的,都是找到某一个位置最大的值(好吧 我不知道怎么说清楚这个东西 可能我理解的不深刻)。1800要用scanf输入,这题的坑点在于可能从高房间号搬向低房间号,因此每次做标记运算的时候,要先比较大小(解释的一塌糊涂,囧)。
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int main(int argc, char *argv[])
{
    int T;
    cin>>T;
    int a[205];
    int n;
    int x,y;
    while(T--)
    {           
        cin>>n;
        memset(a,0,sizeof(a));
        while(n--)
        {
            cin>>x>>y;
            int temp;
            if(x>y)
            {
                temp=x;
                x=y;
                y=temp;
            }
            if(x&1==1)
            ++x;
            x=x/2;
        //  cout<<x<<endl;
            if(y&1==1)
            ++y;
            y=y/2;
        //  cout<<y<<endl;
            for(int i=x;i<=y;i++)   
            ++a[i];
        }       
        sort(a,a+205,cmp);
        cout<<a[0]*10<<endl;        
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值