HDU~2025
查找最大元素
Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
Sample Input
abcdefgfedcba xxxxx
Sample Output
abcdefg(max)fedcba x(max)x(max)x(max)x(max)x(max)
代码:
#include<stdio.h>
#include<string.h>
int main()
{
int i;
char str[110],max;
while(gets(str)){
max=str[0];
i=1;
while(str[i]){
if(str[i]>max) max=str[i];
i++;
}
i=0;
while(str[i]){
printf("%c",str[i]);
if(str[i]==max) printf("(max)");
i++;
}
printf("\n");
}
return 0;
}
注:gets()在读入正确的情况下,返回字符串的首地址,只有在错误读入或者读到文件末时才返回NULL.