hdu 3507Print Article

Print Article

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5443    Accepted Submission(s): 1678


Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤  500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
  
  
5 5 5 9 5 7 5
 

Sample Output
  
  
230
 

这道题是斜率优化dp的典型题目,具体思路参考:点击打开链接

不过非常不幸,一开始我斜率是用double直接除了,一直WA。后来看了别人的代码,发现都是分 分子和分母写的,于是也改成这种风格,终于AC了。

看来这么一小点的误差都不容许啊,以后要小心了。注意:这道题分母是负数,分母乘过去时不等号要改变。


#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 500010
using namespace std;

int q[Maxn];
long long sum[Maxn],dp[Maxn];
long long fun_up(int a,int b){
    return dp[a]-dp[b]+sum[a]*sum[a]-sum[b]*sum[b];
}
long long fun_dn(int a,int b){  //负数
    return 2.0*(sum[a]-sum[b]);
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=n;i++){
            scanf("%I64d",sum+i);
            sum[i]+=sum[i-1];
        }
        dp[0]=0,dp[1]=sum[1]*sum[1]+m;
        int front=0,rear=1;
        q[0]=0,q[1]=1;
        for(int i=2;i<=n;i++){
            while(front<rear&&fun_up(q[front],q[front+1])>=sum[i]*fun_dn(q[front],q[front+1]))
                ++front;
            int j=q[front];
            dp[i]=dp[j]+(sum[i]-sum[j])*(sum[i]-sum[j])+m;
            while(front<rear&&fun_up(q[rear-1],q[rear])*fun_dn(q[rear],i)>=fun_up(q[rear],i)*fun_dn(q[rear-1],q[rear]))
                --rear;
            q[++rear]=i;
        }
        printf("%I64d\n",dp[n]);
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值