poj 1442 Black Box

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7385 Accepted: 3022

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

这道题原本是可以用一个大顶堆和一个小顶堆维护的。但是这几天刚刚学了一堆BST的理论知识,想试试手刷道题啊。代码风格参考刘汝佳的,个人觉得非常好!只是中间有用到动态分配内存和释放空间,不熟悉的话,还是参考其他风格的代码吧,也有纯数组版的,好像SBT就是。这是后话,以后再学吧!先发第一题AC代码。

额,这题求第k大数,元素可能有重复。

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<ctime>
#define Maxn 30010
using namespace std;

struct treap{
    treap *ch[2];  //左右子树
    int r;  //修正值,数值越大,优先级越高
    int v;  //值
    int s;  //附加域
    treap(){}
    treap(int vx):v(vx){ch[0]=ch[1]=0;r=rand();s=1;}
    int cmp(int x)const{
        if(x==v) return -1;
        return x<v?0:1;
    }
    void maintain(){
        s=1;
        if(ch[0]) s+=ch[0]->s;
        if(ch[1]) s+=ch[1]->s;
    }
};
//d=0代表左旋,d=1代表右旋
void rotate(treap* &o,int d){
    treap* k=o->ch[d^1];o->ch[d^1]=k->ch[d];k->ch[d]=o;
    o->maintain();o=k;
}
//在以o为根的子树中插入键值x,修改o
//插入前,先调用find,确保元素不存在
void insert(treap* &o,int x){
    if(!o) o=new treap(x);
    else{
        int d=x<o->v?0:1;
        insert(o->ch[d],x);
        if(o->ch[d]->r>o->r) rotate(o,d^1);
    }
    o->maintain(); //插入后回溯
}
//删除前,先调用find,确保元素存在
void remove(treap* &o,int x){
    int d=o->cmp(x);
    if(d==-1){
        treap* u=o;
        if(o->ch[0]&&o->ch[1]){
            int d2=(o->ch[0]->r>o->ch[1]->r?1:0);
            rotate(o,d2);
            remove(o->ch[d2],x);
        }
        else{
            if(!o->ch[0]) o=o->ch[1];
            else o=o->ch[0];
            delete u;
        }
    }
    else remove(o->ch[d],x);
    if(o) o->maintain(); //删除后回溯
}
bool find(treap* o,int x){
    while(o){
        int d=o->cmp(x);
        if(d==-1) return true; //存在
        else o=o->ch[d];
    }
    return false; //不存在
}
int kth(treap* o,int k){ //第k大值
    if(!o||k<0||k>o->s) return 0;
    int s=o->ch[0]?o->ch[0]->s:0;
    if(k==s+1) return o->v;
    else if(k<=s) return kth(o->ch[0],k);
    return kth(o->ch[1],k-s-1);
}
void print(treap* o){
    if(o){
        print(o->ch[0]);
        printf("%d %d*****",o->v,o->s);
        print(o->ch[1]);
    }
}
int a[Maxn];
int main()
{
    srand((unsigned)time(NULL));
    int m,n,op;
    treap *o=0;
    while(~scanf("%d%d",&m,&n)){
        for(int i=0;i<m;i++)
            scanf("%d",a+i);
        for(int i=0,j=0;i<n;i++){
            scanf("%d",&op);
            while(j<op) insert(o,a[j++]);
            printf("%d\n",kth(o,i+1));
        }
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值