poj 1751 Highways

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9137 Accepted: 2548 Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

这道题目目测用kruskal算法写会很简单,为了继续练习prim算法,活活得把自己坑死了,本来记录路径是可以用两个数组的,这题因为有些路径是建好的(权值为0),这样权值为0时,是不能更新路径的,并且由于每一个点加入生成树,会将其lowcost改成-1,这个时候这些点路径不要去更新,因为这些早已被加入,路径早已更新完成。另外第一个加入的点是没有路径的。这道题目数据时double型的,因此在判不等于-1或者0是要小心。强烈建议在开一个数组vis数组,记录点有没有被加入生成树,这样就不用修改lowcost数组了,不容易出错。

代码:

#include<cstdio>
#include<iostream>
#include<cmath>
#define Maxn 760
#define eps 1e-6
using namespace std;

int x[Maxn],y[Maxn],nearvex[Maxn];
double adj[Maxn][Maxn],lowcost[Maxn];
double dis(int i,int j){
    return sqrt(double(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
bool judge(int x){
    if(abs(lowcost[x]+1)<eps) return true;
    return false;
}
void prim(int u,int n){
    for(int i=1;i<=n;i++){
        lowcost[i]=adj[u][i];
        if(abs(lowcost[i])>eps) nearvex[i]=u;
        else nearvex[i]=-1;
    }
    nearvex[u]=-1;
    for(int i=1;i<n;i++){
        double minn=100000000;
        int v;
        for(int j=1;j<=n;j++)
            if(!judge(j)&&lowcost[j]<minn)
                minn=lowcost[j],v=j;
        for(int j=1;j<=n;j++){
            if(adj[v][j]<lowcost[j]){
                lowcost[j]=adj[v][j];
                if(abs(lowcost[j])<eps) nearvex[j]=-1;
                else if(j!=v) nearvex[j]=v;
            }
        }
    }
    for(int i=1;i<=n;i++)
        if(nearvex[i]!=-1)
            printf("%d %d\n",nearvex[i],i);
}
int main()
{
    int n,m,a,b;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d%d",x+i,y+i);
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
            adj[i][j]=adj[j][i]=dis(i,j);
    for(int i=1;i<=n;i++) adj[i][i]=-1;
    scanf("%d",&m);
    while(m--){
        scanf("%d%d",&a,&b);
        adj[a][b]=adj[b][a]=0;
    }
    prim(1,n);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值