poj 3268 Silver Cow Party

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12929 Accepted: 5785

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

这道题目其实就是正反向建两幅图,然后从源点x来两遍spfa,正向建图时,得到的是返回时的最短路,反向建图时得到的是去参加派对的最短路。

可惜这题一直WA啊,跪得要哭了,一直觉得代码没错啊。后来终于发现了,原来是队列开小了,因为我是自己手写队列,因此队头指针在不停地往后挪,因此尽管队列中最多顶点个数,但是其实下标会大于顶点总数的,这里要开大,如果不想用STL,又不确定开多大,那只能写循环队列了。


代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxv 1010
#define Maxe 100010
using namespace std;

struct line{
    int to,w;
    line(){}
    line(int t,int ww):to(t),w(ww){}
}edge[Maxe],redge[Maxe];
int head[Maxv],rhead[Maxv],nxt[Maxe],rnxt[Maxe];
int q[Maxe],vis[Maxv],dist[Maxv],rdist[Maxv];
const int inf=1<<30;
void spfa(int u,int n,int *dist,int *head,int *nxt,line *edge){
    for(int i=1;i<=n;i++)
        dist[i]=inf;
    dist[u]=0;
    memset(vis,0,sizeof vis);
    int s=0,e;
    q[e=0]=u;
    while(s<=e){
        int v=q[s++];
        vis[v]=0;
        for(int i=head[v];i!=-1;i=nxt[i]){
            int r=edge[i].to,w=edge[i].w;
            if(dist[v]+w<dist[r]){
                dist[r]=dist[v]+w;
                if(!vis[r]) q[++e]=r,vis[r]=1;
            }
        }
    }
}
int main()
{
    int n,m,x,fr,to,w;
    while(~scanf("%d%d%d",&n,&m,&x)){
        memset(head,-1,sizeof head);
        memset(rhead,-1,sizeof rhead);
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&fr,&to,&w);
            edge[i]=line(to,w),nxt[i]=head[fr],head[fr]=i;
            redge[i]=line(fr,w),rnxt[i]=rhead[to],rhead[to]=i;
        }
        spfa(x,n,dist,head,nxt,edge);
        spfa(x,n,rdist,rhead,rnxt,redge);
        int ans=0;
        for(int i=1;i<=n;i++)
            ans=max(ans,dist[i]+rdist[i]);
        printf("%d\n",ans);
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值